Tesla1856

Alienware Aurora-R1 - Windows-10 Pro Upgrade - Smooth sailing so far.

Discussion created by Tesla1856 Expert on Mar 25, 2016
Latest reply on Jul 28, 2017 by Tesla1856

I usually do clean-installs on major OS upgrades. Until recently, I haven't done an in-place upgrade-install like this in many years (manly because it never really worked 100% in other versions).
 
I think Microsoft's Win-10 Upgrade Offer is causing a resurgence in this method. I have performed several now lately (on various machines), and it seems to work pretty good. I think this can be attributed to the fact that the OS is more of a separate layer now (and separately maintain-able). You can tell Microsoft put some effort into this feature. This way certainly saved a lot of time, and seems to be working fine ... long-term.
 
So, instead of battling through a traditional Clean-Install ... formatting, installing OS fresh, finding and installing latest drivers and driver-utility-suites, re-installing programs (sometimes requiring keys and updates), and re-integrating your data-stores ... you let Windows do the Upgrade and then you just test stuff.

This machine was purchased in 2010 and still works perfectly fine. While I wasn't looking forward to messing with the OS on my main system (I run my business and do my development work on it) I figured it was time since it was now two Windows version behind.

First step is a full-system Imaged Backup (with Verify on) to some kind of external storage. I used my old-trusted Acronis-2010, but Macrium Reflect (Free) should also work. Even a Microsoft Backup or straight-file copy of important files is better than nothing.
 
It was originally Dell-Alienware-OEM "Windows-7 Ultimate (64 bit)". After the 2.5 hour Upgrade (go do something else) ... Control-Panel now shows "Windows 10 Professional (64 bit). Windows is Activated. Ran Command Prompt> ver = Microsoft Windows [Version 10.0.10586] ... which is TH2 or Threshold-2. It carries the build number 10.0.10586 and version 1511, referencing its date of release, November 2015.
 
All my internal hardware is fine (as reported in Device Manager). For my AMD Radeon HD-5870, Microsoft provided a working DX-11 driver (v15.201.1151.1008 - 11/4/2015) and a working version of Catalyst Command Center.
 
The only driver I have installed manually is Alienware Command Center AWCC 2.8.11.0 in Win-8 Compatibility-Mode. I think AWCC 2.8.11.0 is a good match due to it's Win-8 Compatibility and updated MIO-Filter Driver. Like always with AW-CC, I clean-installed it (uninstalled old, reboot, install proper version, reboot). No other core-hardware drivers required my attention so far (Microsoft is taking care of all that ... either during initial upgrade or in recent Windows Updates).

 

I think AW-CC v2.8.11.0 is as high as I can go on this Aurora-R1 model. As always (with Alienware desktops with full MIO-Boards), I turn-off Windows-10 Fast Startup. I also don't just Reset Windows ... instead, I always Shut-Down completely and use the top Power Button to boot up again. In Thermal Controller, be sure Task-Tray app is set to "Windows Startup". Set Thermal Controller to Manual (User Control) and nice up-hill Curves on all Fans.

 

 

Regarding "Devices and Printers". The scanner part on my new Canon MF217w MFP ($100 ... what-a-deal) wasn't working so I just uninstalled the whole driver suite and clean-installed the newer Win-10 compatible drivers from Canon.com (quick and easy-peasy lite-driver-install ... Printer, Fax, and Scanner all working over WiFi network). All my other network devices, network printers, USB devices, etc. seem to work fine also.
 
The only exception is the Dell 365 Bluetooth Module (Broadcom-based but proprietary interface). No hope for it but I'm guessing it has something to do with it being connected to proprietary USB-Hub on MIO-Board. No problems since an after-market external USB Bluetooth dongle is only $15. Plus, you can get one that supports newer/better versions of Bluetooth, and it's "antenna" will end-up outside the metal-frame of the machine.
 
I was surprised to see all my Apple iOS devices (iPhone-5 and iPad-2), iTunes, and iCloud Sync stuff was still authorized to this computer and working without any intervention. This includes no problems with purchases or DRM content when various devices were connected or recently sync-ed. If you have ever formatted and clean-installed your Windows and then went to get all your Apple stuff working again, you will likely welcome this news.
 
Most of my programs (Microsoft Office, Visual Studio, some Adobe programs, etc.) and games (DRM via Steam, Origin, Uplay, and standalone-installs) are also working fine. I've tested most (but not all) of them by now. I'm expecting some games might need a compatibility switch or patch here-or-there. Don't think that Microsoft scans every installed program for 100% Windows-10 compatibility. This "build-up" is several years old now, so many programs and utilities are installed. I'll just keep using machine, running programs, and testing them as I go along. I guess its really just "business as usual" with Windows program compatibility in general.

I'm mostly still using IE-11 in Enhanced Protected Mode (and 64-bit Tab Processes) while I get used to using the new Edge browser more full-time. Google Chrome is also installed (as an alternative). You don't have to run any Metro/Modern/Universal Apps if you don't want to, but you might want to checkout the Outlook.com Apps Collection in your browser ... if you haven't already (to see what else Microsoft has been up to ... their answer to Google Apps).
 
I've been running Win-10 on this machine for about 2 weeks now and it seems fine to me. I'm still logging-in with a Local Account. If you are mainly a Windows desktop user (but new to Win-10), I suggest you Pin the old Control Panel to the TaskBar or just Right-Click the Start-Button (or press WinKey-X). You might still have to use the Immersive-Control-Panel (PC Settings) a little bit sometimes, but that's ok. Windows File Explorer is back to working and looking fairly normal (as compared to Win-8), so that's good. With a little customization time, you can probably setup the normal Start-Menu and Tiles to handle your main programs pretty good (try right-clicking a program shortcut icon and Pinning it to either the Start-Menu or Task-Bar).

If you miss your All-Programs Start-Menu in your own custom folders (what was Microsoft thinking ... getting rid of this), check-out Classic-Shell http://www.ClassicShell.net . I only use the StartMenu part (not the Explorer replacement). In general, when new to Win-10 take it slow and do your normal Windows things (but try to checkout the new stuff when you can). 
 
Also did a Clean-Install on a Dell laptop:
 
I also just did a Windows-10 clean-install on my Win-8 laptop ... to a blank (all partitions removed) SSD, and booted it up from newly created Win-10 TH2 USB-Flash-Drive (used Media Creation Tool). It took about 30 minutes (also with a SSD). This one is login-setup with an Online Account (my old MSN email account). So, clean-installs take less than half the time of an upgrade-install.  It appears to be the Migration of existing programs and driver-suites that take a lot of time. Interesting, that in Programs and Features on my Aurora-R1, it even changes the install date of some of the entries to the date of the Win10-Upgrade (when the Windows Upgrade Migration "re-installed" them).
 
More Upgrade & Update Troubleshooting Notes & Tips:
 

Alienware computers are just normal Windows computers and "Windows Update" like any other.

If Updates are Failing to Install, you can try the Microsoft Windows Update "Fix Tool".

support.microsoft.com/.../10164

Also, try with a real Ethernet wire instead of WiFi. Be sure you have plenty of room on C: drive.
 
If that doesn't work, you can try DISM command lines:

www.windowscentral.com/how-use-dism-command-line-utility-repair-windows-10-image

You should never be getting a BlueScreen. That points to a different problem.

Outcomes