AnsweredAssumed Answered

Alienware 18 R3 - USB3.0 Port Dysfunctional

Question asked by ddbug on Aug 8, 2017
Latest reply on Aug 8, 2017 by Alienware-Eimy

I have an Alienware 18 R3, currently running Win8.1.  It has four USB3.0 ports, with one of them having PowerShare.

Previously, when it was running Win10, I kept receiving the alert stating something like "USB port overcurrent".

Then, I formatted the system disk C: and reinstalled Win8.1, BIOS 12 and all the recommended drivers and software from Dell support site.

Now, one USB port became dysfunctional anyway.  The other three worked with USB memory sticks and portable HDDs, but only the one with PowerShare worked with external mouse and touchpad. 

When I run the hardware check from Dell, analyzing USB ports, it shows: Devices causing overcurrent:  2 items, and devices with general failures: 1 item, functioning devices: 5 items, while I actually did not plug in any USB devices in the ports.

Could someone help with this issue?  Is it caused by software or hardware (motherboard)? 

Many thanks for your help in advance!!!

Outcomes